0
Searching answer

Excerpt doesnt works in chinese

Martina 1 week ago updated 2 days ago 8
Hello Andrei,
on this page the excerpt does not show html nor the set length. But on the English page everything works correctly.

https://www.hueller-hille.com/zh/%E8%81%8C%E4%B8%9A%E5%8F%91%E5%B1%95/%E5%8A%A0%E5%85%A5%E6%83%A0%E4%B9%90%E5%96%9C%E4%B9%90/#stellenangebote

Can you tell me why this is?

Searching answer

Hello


Can you attach a screenshot of your excerpt settings?

And please send me some text examples in Chinese with which you have problems.

--

Best Regards

Andrei S.

Hello Andrei,

It's not the characters, it's the language. I have the English texts output here, but here HTML is not interpreted at all. As if other rules would apply to this language.

Thanks for help!

Kind regards,

Martina

I have not done any settings here, it is the same text as in English and there it works.

Kind regards,

Martina

Hello Martina,

I couldn't reproduce your problem.

What is your exact post content? Switch to Code Editor on the edit page and check it.


--

Best Regards

Andrei S.

Hi Andrei,

it's not the output but the language code that gets the page. As I said it's the same content as in English, so I didn't use Chinese characters. Have you created a language and tested it there? Please don't use any characters but put in the Chinese language if you test this then you will see the problem it is probably because of the language code "locale-zh-cn".

I have an HTML output in German and English, but in Chinese this is not displayed.

Kind Regards,

Martina

Hi Martina,

The problem is in option "Number of Words". Try to make it bigger in the Chinese version. For example - 1500

--

Best Regards

Andrei S.

Hi Andrei,

ok that makes little sense, because I use the same settings as in englsichen and there the content is displayed. I had to set the value now to over 2000, then everything was displayed to me. Thanks a lot!

Kind regards,
Martina